LPA configuration not being pushed

  • 2 June 2021
  • 3 replies
  • 152 views

  • Anonymous
  • 0 replies

There may be numerous reasons for the LPA configuration to not be pushed from LogPoint to the agents. The following are some of the things that you can easily check before contacting LogPoint Support.

  1. Check if the Windows machine is actually running or not. This might seem trivial, but there are instances where the windows machines are not functioning in the first place.
  2. Run the telnet command on the device for port 7994 and 7995. Since these are the ports via which the configurations are pushed, this might be an issue with the lpagents which are deployed on the log source. You can also check if  ports 7994 or 7995 are open on the device's end as well.
  3. Verify that the configured device is not configured as NAT IP. If NAT IPs are being used, then the configuration will need to be copied manually to the correct directory; C:\Program Files (x86)\lpagent\conf\lpagent.conf
  4. If the configuration is still not being pushed, create a support ticket with the below information:
    • LPAgent log files present on C:\Program Files (x86)\lpagent\data\lpagent.log
    • Logs present on /opt/immune/var/log/service/lpa_manager/current

3 replies

Userlevel 1
Badge

Question to the NAT Thing:

If i change the Configuarion of the (working) NAT Device (add a custom Flat File to collect) - do i have to update the Config File Manually or is this config item added automatically?

Hello Kai,
The LogPoint instance attempts to push the lpagent configuration regardless of any changes made or not, every few minutes. For NAT IP addresses, as LogPoint cannot reach said IP address, the configuration push fails. Hence, the log source will not receive the new configuration for lpagent. For the lpagent to forward the contents of the Flat File, you must download the updated config from the UI and copy the config to the log source manually.

Userlevel 1
Badge

Hi,

so i have to configure the Device with the UnNATted IP original local IP?

Actual i configured the Device in LogPoint with the NAT IP - So it (theoretical) can reach the remote Agent.

*confused*

Reply